User Tag List

Page 36 of 36 FirstFirst ... 263233343536
Results 1,751 to 1,783 of 1783

Thread: [Technical] Possible Solutions to your Phantom's Problem

  1. #1751
    Raywjj92
    has no status.
    L Plate
    Join Date
    Jun 2016
    Posts
    1
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default



    Hi, I recently got my license and bought a phantom ta150. I have some issues with my signal lights and I don't know what is wrong with the lights. Can some one please help me? Thank you thank you

    Problem: Left signal light not blinking, emitting dim constant light.

  2. #1752
    BoysLikeChix
    has no status.
    L Plate
    Join Date
    Oct 2015
    Posts
    12
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Raywjj92 View Post
    Hi, I recently got my license and bought a phantom ta150. I have some issues with my signal lights and I don't know what is wrong with the lights. Can some one please help me? Thank you thank you

    Problem: Left signal light not blinking, emitting dim constant light.
    Eh try changing bulb, shouldnt cost more than 5 bucks for one signal bulb. If problem persist, go to a motorshop and check wiring. I doubt its the battery. Because I think signal lights consume lesser voltage compared to headlights? If its battery, alot of other problems will surface.

     

     
  3. #1753
    amit2410
    has no status.
    L Plate
    Join Date
    Apr 2016
    Posts
    19
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I have just passed my 2B and decided to get an Old phantom instead of new bikes.

    Its a 13 year old phantom 200 I hope it wont disappoint me for its last 2 years of life.

    I am having some issues that I would like to know about before i head to workshop for service/oil change.

    1. Left signal indicator does not blink. just lights up. But right indicator works fine and blinks. Wiring/Ground issue?

    2. Key in switch ON position turns on the headlight. Is it normal?

    3. Steering sharp left in slow turns makes some crackling noise. I wonder what is it.

    4. Engine feels very hot after riding for some time and i can feel the heat near my feet. Gear shifting becomes dodgy as well.

    5. While riding, the engine backfires when i close throttle. (poop..poop.. noise coming from exhaust). is it bad?

    6. Going straight feels like the handle bars are slightly bent to the right. Is it fixable?

    7. The footpegs seem bent/deformed, causing uncomfortable riding posture for my legs. Is it expensive to replace them?


    Any helpful comment is much appreciated. Forgive my noob questions.

    Thanks

  4. #1754
    amit2410
    has no status.
    L Plate
    Join Date
    Apr 2016
    Posts
    19
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by safsikal View Post
    1. Possibly signal relay.
    2. Normal-legal requirement actually.
    3. Where is the sound coming from? wheel hub? -possibly wheel bearings.
    4. Normal. Shifting dodgy try new oil if the servicing is due.
    5. Some riders like it. Won't 'kill' the bike. Can adjust the carb or check PAIR system.
    6. Pressure off the handlebar n recheck. Usually the gyro effect will straighten the bike. Loosen n re-tighten fork bolts.
    7. Change them. Price related to taste.

    Have fun.
    Thank you so much for your reply.
    Went to workshop yesterday.
    I have solved the signal issue by changing relay.
    I changed engine oil, plug and air filter. Now engine feels better.

    I will check the carburator and wheel bearing next time like u mentioned.

    The mechanic said my front brake disc needs to be replaced and Quoted $85. Too much?

    I have another problem regarding riding comfort.
    For some reason my tailbone hurts badly after 20min of riding. And butt becomes numb. Is it the seat or my posture?
    The seat was replaced by previous owner and is fairly new.
    Where can i find seat with more padding to ease on my butt?

    Thanks again

  5. #1755
    ber
    has no status.
    Class 2A
    Join Date
    Jun 2013
    Posts
    665
    Feedback Score
    0
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Default

    The disc price is about there. You can try adjusting the handle, you can add padding at Eugene saddlery at Japan Berseh.

  6. #1756
    amit2410
    has no status.
    L Plate
    Join Date
    Apr 2016
    Posts
    19
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by ber View Post
    The disc price is about there. You can try adjusting the handle, you can add padding at Eugene saddlery at Japan Berseh.
    Thanks so much i will find the shop.

  7. #1757
    amit2410
    has no status.
    L Plate
    Join Date
    Apr 2016
    Posts
    19
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I found in the parking today its really hard to push the bike backwards. but its easy to push towards front.

    Feels like something is stuck and not letting the wheels move reverse. had to use a lot of energy to push it back out of the lot.

    Any ideas?

  8. #1758
    amit2410
    has no status.
    L Plate
    Join Date
    Apr 2016
    Posts
    19
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by safsikal View Post
    Take opportunity to ask mechanic to check when you change brake disc. Suspect disc or caliper warp. If problem persist upon disc change then caliper service/replacement may be required. Previous owner may have dropped the bike.
    Thanks..I serviced both brakes..basically opening the calipers and sand it..atleast thats how i remember the mechanic did.
    front brake seemed to be the problem...now its all good...

  9. #1759
    am92
    has no status.
    L Plate
    Join Date
    Feb 2015
    Posts
    27
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I have been having issue with very loud tapping noise from the engine when idling both hot and cold. Went to planet and ah chong told me the noise is due to piston being worn out and making the noise. He told me the engine still can last approx 3-4 months and thereafter needs a top overhaul. I believe my engine is still strong and compression should be good cos my bike can go up to 130kmh without any issues. Engine oil consumption is pretty standard for all phantoms, need top up every now and then but no white smoke coming out of exhaust. Im now considering if the problem is due to my valve clearance, which i believe is the most common top end noise from engines. Engine is still in original condition, never overhauled before. Valve clearance probably never done either. 180k mileage.
    Appreciate any input of any pros here. Thanks

  10. #1760
    crossbone
    has no status.
    L Plate
    Join Date
    Nov 2012
    Posts
    14
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hey all,

    Left my phantom for an overseas trip for about 2 month.
    Came back and found the bike can't start and lights are off on standby (so I guess its the battery).
    Any advise on how should i handle this ? Thinking of just get it towed to ahkoon but wondering if its cheaper if i try to handle it myself first.
    thanks!

  11. #1761
    am92
    has no status.
    L Plate
    Join Date
    Feb 2015
    Posts
    27
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    You can try jump start the bike. With ignition on, kick the bike to 6th gear, clutch in and push the bike fast enough that you at a sprinting speed. Release the clutch and you can hear the bike starting up and quickly clutch in so the bike doesnt stall. Let the bike running for a while to let the battery recharge. Go for a few rounds around your estate maybe like 10 mins and it should be back to normal if the issue is the battery drained. Otherwise ride it to mechanic to get it checked.

     

     
  12. #1762
    Silent Hunter
    has no status.
    SBF Lacer Silent Hunter's Avatar
    Join Date
    Jun 2007
    Location
    Singapore, Yishun
    Posts
    5,129
    Feedback Score
    4 (100%)
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default

    Yes, can push start. you can even take the battery out and keep it at home to save weight, then go to a motorshop and buy a new battery.
    Motorcyclist are the nicest people on the road, try not to kill us.

  13. #1763
    questereq
    has no status.
    L Plate
    Join Date
    Apr 2014
    Posts
    3
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Fuel Leaking with Pet Cock at ON During Park

    Hi all.

    Fuel seems to be leaking on my TA200 when parked with pet cock at the "on" position. I noticed the carb area wet and eventually a small puddle of fuel pools under the bike. Turning to the "off" position seems to fix the problem.

    With the bike running, the lower half of the carb area seems to be slightly moist too, also with fuel.

    Any idea what the fault is?

    Thanks!

  14. #1764
    am92
    has no status.
    L Plate
    Join Date
    Feb 2015
    Posts
    27
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    there is a screw at the bottom of the carb with a hose attached to it. try tightening it with a flat head screwdriver first. if it still doesnt work, its most probably the carb gasket is worn. should go get it changed.

  15. #1765
    barbaricboon
    has no status.
    P Plate
    Join Date
    Feb 2010
    Posts
    59
    Feedback Score
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi everyone. anyone got any idea where to get a TA200 exhaust header?? Mine rusted until cannot rust liao. Just a 2nd hand or refurbished 1 will do. Much thanks

  16. #1766
    Chenyi
    has no status.
    L Plate
    Join Date
    Oct 2017
    Posts
    5
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Bike no power

    Hello everyone, I just got my license and decided to get a 10 year old TA 200. I have been riding the bike for 3 months now and realised that my bike really lacks power. It has a top speed of 100, struggles to accelerate from 80 onwards. It accelerates from 0 to 80 easily but the throttle just feels spongy and unresponsive after that. Any ideas why it could be happening?

    Millage is only 60k

  17. #1767
    Kev's
    tendered for resignation as a
    SBF Moderator Kev's's Avatar
    Join Date
    Mar 2004
    Location
    adventure, alone, somewhere, out there.
    Posts
    10,735
    Feedback Score
    26 (100%)
    Mentioned
    28 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by Chenyi View Post
    Hello everyone, I just got my license and decided to get a 10 year old TA 200. I have been riding the bike for 3 months now and realised that my bike really lacks power. It has a top speed of 100, struggles to accelerate from 80 onwards. It accelerates from 0 to 80 easily but the throttle just feels spongy and unresponsive after that. Any ideas why it could be happening?

    Millage is only 60k
    my hunch, probably needs an engine overhaul.

    since u mentioned 10yo bike with 60K mileage.

    6th gear could be gone also.

    unless u wana ride for long, otherwise just ride for experience & then save to upgrade when u can.

    cheers!
    我们都在不断赶路 忘记了出路 在失望中追求偶尔的满足

    Disclaimer:

    The above information is obtained from third party sources for which I assume no responsibility.
    While there is no reason to believe that the information is unreliable, no liability is accepted for any errors or inaccuracies.™®©


  18. #1768
    kzone
    has no status.
    Class 2
    Join Date
    May 2007
    Posts
    1,135
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Chenyi View Post
    Hello everyone, I just got my license and decided to get a 10 year old TA 200. I have been riding the bike for 3 months now and realised that my bike really lacks power. It has a top speed of 100, struggles to accelerate from 80 onwards. It accelerates from 0 to 80 easily but the throttle just feels spongy and unresponsive after that. Any ideas why it could be happening?

    Millage is only 60k
    10 yr old bike with 60k mileage likely means actual mileage is 160K

    something is not right if cant go beyond 100, but u can feel the bike doesn't like to be pushed beyond 100 n will likely experience piston jam if u push it beyond 100 constantly.

    Btw, I recall phantom is only 5 gears?

    If u r gonna ride the bike for at least 2 more years, quite worth it to a do a overhaul, change clutch plates, ball bearing, tyres, brakes... It'll feel like a new bike.
    Liverpool revival has started....

  19. #1769
    Chenyi
    has no status.
    L Plate
    Join Date
    Oct 2017
    Posts
    5
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Kev's View Post
    my hunch, probably needs an engine overhaul.

    since u mentioned 10yo bike with 60K mileage.

    6th gear could be gone also.

    unless u wana ride for long, otherwise just ride for experience & then save to upgrade when u can.

    cheers!
    Ahh, I see. I have a 6th gear but it has no power to accelerate, I guess that's normal for a crusing gear? I just painted the entire bike, this phantom is going to last me till I graduate from university hahaha. Thanks for the reply!


    Quote Originally Posted by kzone View Post
    10 yr old bike with 60k mileage likely means actual mileage is 160K

    something is not right if cant go beyond 100, but u can feel the bike doesn't like to be pushed beyond 100 n will likely experience piston jam if u push it beyond 100 constantly.

    Btw, I recall phantom is only 5 gears?

    If u r gonna ride the bike for at least 2 more years, quite worth it to a do a overhaul, change clutch plates, ball bearing, tyres, brakes... It'll feel like a new bike.
    I thought I got a good deal on a less used bike hahaha. The funny thing is that it can still go to 100 when I am carrying a pillion... I think it will be a good investment to do an engineer overhaul. What would be a good shop to go to? I heard good things about ah koon and planet motors from this forum. Thanks for the advice man!

  20. #1770
    kzone
    has no status.
    Class 2
    Join Date
    May 2007
    Posts
    1,135
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Chenyi View Post
    Ahh, I see. I have a 6th gear but it has no power to accelerate, I guess that's normal for a crusing gear? I just painted the entire bike, this phantom is going to last me till I graduate from university hahaha. Thanks for the reply!




    I thought I got a good deal on a less used bike hahaha. The funny thing is that it can still go to 100 when I am carrying a pillion... I think it will be a good investment to do an engineer overhaul. What would be a good shop to go to? I heard good things about ah koon and planet motors from this forum. Thanks for the advice man!
    yeah, just go planet for non cosmetic stuffs.

    So phantom really got 6 gears? which version ah?
    Liverpool revival has started....

  21. #1771
    Chenyi
    has no status.
    L Plate
    Join Date
    Oct 2017
    Posts
    5
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by kzone View Post
    yeah, just go planet for non cosmetic stuffs.

    So phantom really got 6 gears? which version ah?
    Went to planet today, uncle say 100 can help me fix. He said my carb is busted. I wanted to fix another day so I rode my bike back, 10 mins breakdown on PIE. Still waiting for tow... 3 hours liao

     

     
  22. #1772
    Kev's
    tendered for resignation as a
    SBF Moderator Kev's's Avatar
    Join Date
    Mar 2004
    Location
    adventure, alone, somewhere, out there.
    Posts
    10,735
    Feedback Score
    26 (100%)
    Mentioned
    28 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by Chenyi View Post
    Ahh, I see. I have a 6th gear but it has no power to accelerate, I guess that's normal for a crusing gear? I just painted the entire bike, this phantom is going to last me till I graduate from university hahaha. Thanks for the reply!


    I thought I got a good deal on a less used bike hahaha. The funny thing is that it can still go to 100 when I am carrying a pillion... I think it will be a good investment to do an engineer overhaul. What would be a good shop to go to? I heard good things about ah koon and planet motors from this forum. Thanks for the advice man!
    its not normal for a cruising gear if it doesn't cruise.

    100km/h with pillion is norm, just that stressing more for a worn & tired engine.


    Quote Originally Posted by kzone View Post
    yeah, just go planet for non cosmetic stuffs.

    So phantom really got 6 gears? which version ah?
    frm 1st version to last.


    Quote Originally Posted by Chenyi View Post
    Went to planet today, uncle say 100 can help me fix. He said my carb is busted. I wanted to fix another day so I rode my bike back, 10 mins breakdown on PIE. Still waiting for tow... 3 hours liao
    shld just get it done & over with.

    no need think further rather breaking dwn in the middle of nowhere.
    我们都在不断赶路 忘记了出路 在失望中追求偶尔的满足

    Disclaimer:

    The above information is obtained from third party sources for which I assume no responsibility.
    While there is no reason to believe that the information is unreliable, no liability is accepted for any errors or inaccuracies.™®©


  23. #1773
    Chenyi
    has no status.
    L Plate
    Join Date
    Oct 2017
    Posts
    5
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ah choong changed my carb to a working 2nd hand one for 100. Now my bike works like a charm. Feels so much smoother and more powerful than before. Highly recommend planet motors!

  24. #1774
    am92
    has no status.
    L Plate
    Join Date
    Feb 2015
    Posts
    27
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Phantom 200 is a pretty bullet proof bike. Mine is almost reaching 200k km and still going strong. I can push it up to 130km/h with no problems. Engine overhaul is not necessary unless you see white smoke coming from your exhaust and excessive engine oil consumption. Phantom is known to burn some oil. Just be sure to change your oil on time and check/top up when necessary. A well lubricated engine goes a long way in ensuring the life of the engine.

  25. #1775
    tanghao
    has no status.
    L Plate
    Join Date
    Oct 2017
    Posts
    4
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    wahaha.. thanks for all the info, got it fix already, was the brake lever unti spoil and also my brake disc is out of shap, but the strange thing is i never knock into anything or fall down, so also don't noe why out of shape, total damage is 110, the brake dis is second hand de.. wahaha painful man.. cheers.. but cannot save on the brake man can save out life
    https://www.frontline.com.sg/android-app-development/
    and
    https://www.user.com.sg/web-software-development/

  26. #1776
    Funky
    has no status.
    P Plate
    Join Date
    May 2009
    Posts
    77
    Feedback Score
    0
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi, recently changed the top gasket seals of my TA200. Needed to do so because outside leaking engine oil, it was a big operation.

    Then was changing my spark plug some week ago and noticed black oil on the lower part of the old plug. Also noticed my engine oil level still dropping and need monitoring and top up now and then.

    So guys any ideas what could be wrong? Thanks alot and good day.

  27. #1777
    rogerskenny
    has no status.
    L Plate
    Join Date
    Jan 2019
    Posts
    1
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi All,

    I’ve purchased at Phantom 200 a few months ago.

    Hope you guys can help me out.

    1. Sometimes while accelerating, I have the tick tick sound. I stop throttling and it will stop. It’s kinda on and off. I’ve been reading the forum a lot and there could be an issue with the cam chain tensioner. However, the forum mentioned that I sound change if the tick tick sound is occurring during idle/neutral. I don’t have that issue during idle. Should I continue to ride with the tick tick sound or replace cam chain tensioner?

    2. I have problems changing from gear 1 to neutral while stationary. I have to half clutch and throttle abit then I can change to neutral. Do I need to change my clutch? Or should I just leave it and use this technique to change to neutral while stationary?

    Would appreciate the guidance. Thanks!

  28. #1778
    Kev's
    tendered for resignation as a
    SBF Moderator Kev's's Avatar
    Join Date
    Mar 2004
    Location
    adventure, alone, somewhere, out there.
    Posts
    10,735
    Feedback Score
    26 (100%)
    Mentioned
    28 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by rogerskenny View Post
    Hi All,

    I’ve purchased at Phantom 200 a few months ago.

    Hope you guys can help me out.

    1. Sometimes while accelerating, I have the tick tick sound. I stop throttling and it will stop. It’s kinda on and off. I’ve been reading the forum a lot and there could be an issue with the cam chain tensioner. However, the forum mentioned that I sound change if the tick tick sound is occurring during idle/neutral. I don’t have that issue during idle. Should I continue to ride with the tick tick sound or replace cam chain tensioner?

    2. I have problems changing from gear 1 to neutral while stationary. I have to half clutch and throttle abit then I can change to neutral. Do I need to change my clutch? Or should I just leave it and use this technique to change to neutral while stationary?

    Would appreciate the guidance. Thanks!
    gosh... so long hvnt post in a while..
    almost forgot how to use the forum..

    1) since u mention the ticking sound occurs only when throttling, check yr drivetrain aka chain & sprockets first.
    if that section is fine, then the only thing possibly causing the sound is the CCT.

    2) try adjusting yr clutch cable play first.
    if that is still the same, clutch plates.
    worse case scenario would be the shift shaft mechanism (I think).

    TA200 is rly a relic nowadays, best to get it checked & replace/repair if need be.

    Cheers!
    Kev
    我们都在不断赶路 忘记了出路 在失望中追求偶尔的满足

    Disclaimer:

    The above information is obtained from third party sources for which I assume no responsibility.
    While there is no reason to believe that the information is unreliable, no liability is accepted for any errors or inaccuracies.™®©


  29. #1779
    Septimus
    has no status.
    L Plate
    Join Date
    Jan 2019
    Posts
    3
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Phantom TA200 Carbie Hoses

    My wife has a 2004 Phantom TA200 with 495km on the clock. It has been sitting for 14 years unused and I am getting it going again. I have struck a problem as I have had the carbie off for cleaning and now cannot work out where the myriad of rubber hoses go I have tried to find a service manual but it seems that is nowhere to be found on the internet so I am hoping someone can give me the necessary information. If it can be backed up with photos that would be good.

    By the way, I have looked at the diagram on the side cover but it does not have enough info for me.

    Thanks in advance.

  30. #1780
    Septimus
    has no status.
    L Plate
    Join Date
    Jan 2019
    Posts
    3
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    No replies so far but if I can find a service manual then the problem will be solved. Does anyone have a service manual for sale or know where I can get one?

  31. #1781
    Kev's
    tendered for resignation as a
    SBF Moderator Kev's's Avatar
    Join Date
    Mar 2004
    Location
    adventure, alone, somewhere, out there.
    Posts
    10,735
    Feedback Score
    26 (100%)
    Mentioned
    28 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by Septimus View Post
    My wife has a 2004 Phantom TA200 with 495km on the clock. It has been sitting for 14 years unused and I am getting it going again. I have struck a problem as I have had the carbie off for cleaning and now cannot work out where the myriad of rubber hoses go I have tried to find a service manual but it seems that is nowhere to be found on the internet so I am hoping someone can give me the necessary information. If it can be backed up with photos that would be good.

    By the way, I have looked at the diagram on the side cover but it does not have enough info for me.

    Thanks in advance.

    Quote Originally Posted by Septimus View Post
    No replies so far but if I can find a service manual then the problem will be solved. Does anyone have a service manual for sale or know where I can get one?
    The old lady is 10 over yrs old my dear friend.
    back then the internet hasn't yet so advance so it was either DIY or, send the trusted mech.

    you can try your luck & inquire with FJT but I reckon chances are slim to nought.

    another alternative that I thought it may help was the sticky thread here:
    https://www.singaporebikes.com/forum...ated!-10-12-14
    post #8.

    not sure if it helps thou.

    anyway, for future DIY, suggest you take an overall photo before operating.
    that's what I do.

    Last but not least, think most or all, seldom frequent here nowadays.

    the forum is like, long gone.

    Cheers!
    Kev
    我们都在不断赶路 忘记了出路 在失望中追求偶尔的满足

    Disclaimer:

    The above information is obtained from third party sources for which I assume no responsibility.
    While there is no reason to believe that the information is unreliable, no liability is accepted for any errors or inaccuracies.™®©


     

     
  32. #1782
    Septimus
    has no status.
    L Plate
    Join Date
    Jan 2019
    Posts
    3
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks Kev, appreciate the reply. I did take a photo but it was about two years ago and I have just got around to fixing it. In the meantime the photo has gone to photo heaven

  33. #1783
    safsikal
    has no status.
    L Plate
    Join Date
    May 2017
    Posts
    15
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Septimus View Post
    Thanks Kev, appreciate the reply. I did take a photo but it was about two years ago and I have just got around to fixing it. In the meantime the photo has gone to photo heaven
    Where is ur location? PM me.

Page 36 of 36 FirstFirst ... 263233343536

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •