User Tag List

Page 3 of 35 FirstFirst 123456713 ... LastLast
Results 101 to 150 of 1727

Thread: [Technical] Queries for TA200

  1. #101
    hamsterwhale
    is riding a 1400 camel
    TeePee hamsterwhale's Avatar
    Join Date
    May 2006
    Location
    land of woods in a circle
    Posts
    2,945
    Feedback Score
    0
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)

    Default



    Quote Originally Posted by h@nda View Post
    Hi Guys,

    Recently my TA200 started to give me a problem.

    It goes like that:
    When I was picking up or while cruising, the will be a drawback, as in like pull-back and then goes back normal. I could experience that a few times during my ride. My mechanic thought that it might be the carburetor problem, so he took it out and gave it a good wash. After which he realized that there was a crack line on rubber joint connecting the carburetor to the engine which might be one of the reason why that problem. After changing it, the problem still persist, my mechanic told me that the only thing left now would be the magnetic coil problem.

    Any Bros out there experienced this problem before or heard about it?
    Please give me some advices.
    if its the rubber connector from the air filter to the carb, then yes it'll cause this prob, as carbs uses vacuum to draw apppropriate amts of fuel and air...

    the best example i can quote u is this, imagine a a straw with a tiny puncture, when u sucked the liquid up, there will be air entering the crack, resulting in a slow movement of liquid, same goes to the rubber hose, because the carb and the airbox are supposed to be tight without any leakage of air entering or leaving it, hence performance is degraded, try riding without ur air filter for 10 mins and u'll understand it immediately....

    anyway if the crack is not big u can actually use silicone, or epoxy and mend the crack, but then again, the rubber hose is quite cheap actually less then 30 bucks if my memory serves me correctly...
    Go as far as you can see; when you get there, you'll be able to see farther.
    J. P. Morgan

  2. #102
    hamsterwhale
    is riding a 1400 camel
    TeePee hamsterwhale's Avatar
    Join Date
    May 2006
    Location
    land of woods in a circle
    Posts
    2,945
    Feedback Score
    0
    Mentioned
    22 Post(s)
    Tagged
    0 Thread(s)

    Default

    i forgot to add, if its the magnetic coil, when u travel at low speed, the bike is running normal, but once above 60km/h (roughly lah) u'll exp something similar to ur bike running out of petrol, very sluggish type of movement ie to say "zhua zia"

    so ur coil should not be the prob, as what u mention ur exp only momentary lack of throttle response from ur engine....
    Go as far as you can see; when you get there, you'll be able to see farther.
    J. P. Morgan

     

     
  3. #103
    h@nda
    has no status.
    P Plate
    Join Date
    Jul 2009
    Posts
    156
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks hamsterwhale. I've changed the rubber joint at $40 but still the problem is there.

  4. #104
    mepkoh
    has no status.
    Deregistered
    Join Date
    Feb 2008
    Posts
    2,520
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    a dying cdi may exhibit same symtom...
    if thats the case..further deterioration of cdi will be stalling engine...intermitten until cdi 100% dies.

  5. #105
    h@nda
    has no status.
    P Plate
    Join Date
    Jul 2009
    Posts
    156
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sorry mepkoh, what is cdi?

  6. #106
    mepkoh
    has no status.
    Deregistered
    Join Date
    Feb 2008
    Posts
    2,520
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    cdi=capacitance discharge ignition..i think
    this is the device that control the timing of the discharge of the high voltage to the spark plugs.

  7. #107
    Barack Obama
    has no status.
    L Plate Barack Obama's Avatar
    Join Date
    Feb 2009
    Posts
    30
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    bros, anyone know what is those loose tube (red arrow) hanging down there....in my TA200
    is it normal? for advice..thanks...



  8. #108
    BlackDawn
    has no status.
    SBF Phantom Knights BlackDawn's Avatar
    Join Date
    Mar 2004
    Location
    North
    Posts
    7,482
    Feedback Score
    2 (100%)
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)

    Default

    Yes its normal. Its a breather tube.
    BlackDawn aka kiamh
    "There is no man more free than the one who doesn't give a damn what society thinks of him"

  9. #109
    h@nda
    has no status.
    P Plate
    Join Date
    Jul 2009
    Posts
    156
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    A CDI would be costly?

  10. #110
    jB
    has 4 and counting! :D
    SBF Lacer jB's Avatar
    Join Date
    Jan 2007
    Location
    a place w/out ERP
    Posts
    18,119
    Feedback Score
    0
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)

    Default

    That depends on how much is considered costly to you
    Click below link or copy+paste for good deals!
    http://www.singaporebikes.com/forums/showthread.php/417915-WTS-Shoei-XR-1100-Diabolic-Cimmerian-Mint-Condition-L-Size-CHEAP!-9-8-10?p=8191458#post8191458

    http://www.singaporebikes.com/forums/showthread.php/406472-WTS-Blaupunkt-Style-Headphones-Unopened-BNIB!

  11. #111
    h@nda
    has no status.
    P Plate
    Join Date
    Jul 2009
    Posts
    156
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    or should I say how much would be the range like. =)

     

     
  12. #112
    jtzx
    busy man
    SBF Phantom Knights jtzx's Avatar
    Join Date
    Jan 2009
    Location
    B I S H A N
    Posts
    6,248
    Feedback Score
    8 (90%)
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default

    Quote Originally Posted by Barack Obama View Post
    bros, anyone know what is those loose tube (red arrow) hanging down there....in my TA200
    is it normal? for advice..thanks...


    ur chain need alot of lubbing dude...

    look so dry
    JOSHUA
    class2B -26/2/09
    class 2A -27/7/10
    class 3 - 6/1/11
    class 2 - 30/8/12



  13. #113
    Silent Hunter
    has no status.
    SBF Lacer Silent Hunter's Avatar
    Join Date
    Jun 2007
    Location
    Singapore, Yishun
    Posts
    5,133
    Feedback Score
    4 (100%)
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default

    Yap, the other one with a cap should be a overflow tube, I see a bit of liquid in mine.
    Motorcyclist are the nicest people on the road, try not to kill us.

  14. #114
    mepkoh
    has no status.
    Deregistered
    Join Date
    Feb 2008
    Posts
    2,520
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by h@nda View Post
    or should I say how much would be the range like. =)
    i would guess that a second hand one would cost u up to $100..or a brand new one $300? i am not certain about price...have done one for my steed at $150..
    most bike shop would get u one from a scrap/used, unless u specify u want brand new.

  15. #115
    mepkoh
    has no status.
    Deregistered
    Join Date
    Feb 2008
    Posts
    2,520
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Silent Hunter View Post
    Yap, the other one with a cap should be a overflow tube, I see a bit of liquid in mine.
    this tube is a breather tube from your crank case...most probably the pressure is higher than preset..ie u may have too much EO. if really excessive EO it
    will end up on the floor ( this "leaking EO" will eventually stop,thats why sometimes EO can stop leaking after a while, when the pressure in the crankcase is within the working pressure....)
    the other tube is the overflow tube from your battery casing.( there is one more for water/liquid cool bikes for overflow of the coolent)
    Last edited by mepkoh; 10-08-2009 at 07:55 AM.

  16. #116
    h@nda
    has no status.
    P Plate
    Join Date
    Jul 2009
    Posts
    156
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Alright! Thanks for sharing. =)

  17. #117
    Barack Obama
    has no status.
    L Plate Barack Obama's Avatar
    Join Date
    Feb 2009
    Posts
    30
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by jtzx View Post
    ur chain need alot of lubbing dude...

    look so dry
    Thanks all bros for input...
    jitzx...agree with u...
    since my last service...mileage was 850km...already half year....never ride much..... never go service yet lor...keke
    what is the best lub to use for chain......thinking of diy...
    maxima...or any good lub to share ? thanks

  18. #118
    jtzx
    busy man
    SBF Phantom Knights jtzx's Avatar
    Join Date
    Jan 2009
    Location
    B I S H A N
    Posts
    6,248
    Feedback Score
    8 (90%)
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default

    just any can spray lubb will do.. if you want good job get a maxima lo..
    JOSHUA
    class2B -26/2/09
    class 2A -27/7/10
    class 3 - 6/1/11
    class 2 - 30/8/12



  19. #119
    mepkoh
    has no status.
    Deregistered
    Join Date
    Feb 2008
    Posts
    2,520
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Barack Obama View Post
    Thanks all bros for input...
    jitzx...agree with u...
    since my last service...mileage was 850km...already half year....never ride much..... never go service yet lor...keke
    what is the best lub to use for chain......thinking of diy...
    maxima...or any good lub to share ? thanks
    check this out out .. at the clinic

  20. #120
    mepkoh
    has no status.
    Deregistered
    Join Date
    Feb 2008
    Posts
    2,520
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    At the moment i am working on Verion 2.0 DIY oiler..
    the version works..but have dsiadvantages..ran bike for 50km yesterday and now my chain links are not shining anymore, more like a greasy grey/black..hahah no signs of fling EO.
    Will try to use STP engine EO additive..this one i suppose is super heavy duty EO..hope it can flow..( hampsterwhale"s honey)
    yeah..u can have it after i have done Version 2.0 DIY OILer..maybe i go an register my design..hahah. This DIY oiler is the best yet device added to the my bike

    C and G....
    who say cheap stuff cannot be good...? This one really Good and Cheap...

  21. #121
    Firedragon
    has no status.
    Class 2B Firedragon's Avatar
    Join Date
    Mar 2008
    Posts
    330
    Feedback Score
    0
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)

    Default

    HEy guys, I go a problem here;

    I just changed my steering bracket(Black thing below the headlight) and steering cone. But I still feel abit of steering abit toward the right in order to move my bike in straight running.

    can anyone have any troubleshooting idea??

     

     
  22. #122
    Hydher
    Is selling his GSXR1000
    SBF Phantom Knights Hydher's Avatar
    Join Date
    May 2008
    Posts
    3,551
    Feedback Score
    1 (100%)
    Mentioned
    32 Post(s)
    Tagged
    1 Thread(s)

    Default

    You dare or have the equipments to toggle with? if not, why not just go down to your bike shop? could me anything from bearings to alignment.

  23. #123
    ifourdesign
    | Recreate. Redefine. Redesign
    Class 2B
    Join Date
    Apr 2009
    Posts
    220
    Feedback Score
    1 (100%)
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Anybody know where can i get a tank bra for phantom TA200?

    got into an accident with a damn lorry. bike dented on the left abit.

  24. #124
    munkit
    has no status.
    P Plate
    Join Date
    Oct 2008
    Location
    jurong west
    Posts
    174
    Feedback Score
    0
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default need help urgently

    hey bros,

    currently i have the tick tick sound when cold start.. i haf checked on the forum n it stated its the tensioner right? if for a long term n its not settled.. will it do any harm??? i need replies urgently!!!

    tks a million!!!
    RiDe iF YoU dArE... lOwEr YoU gO... ThE mOrE KiCk yOu Got...BuT mY fOoTrEsT cHuI...
    Passed 2B - 18thMar09'
    Phantom TA200 - FUxxxxK 24thMar09' to 18thJun11'
    RoadWin R125 - FBC****M 23rdJun11'

  25. #125
    chuan.z
    has no status.
    Class 2 chuan.z's Avatar
    Join Date
    Jun 2007
    Location
    SG,SG
    Posts
    1,282
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by munkit View Post
    hey bros,

    currently i have the tick tick sound when cold start.. i haf checked on the forum n it stated its the tensioner right? if for a long term n its not settled.. will it do any harm??? i need replies urgently!!!

    tks a million!!!
    Depends on the ticking, it can be due to valve clearance also.

    http://www.singaporebikes.com/forums...37#post5524237

  26. #126
    mepkoh
    has no status.
    Deregistered
    Join Date
    Feb 2008
    Posts
    2,520
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by munkit View Post
    hey bros,

    currently i have the tick tick sound when cold start.. i haf checked on the forum n it stated its the tensioner right? if for a long term n its not settled.. will it do any harm??? i need replies urgently!!!

    tks a million!!!
    yeah...valve seat may be the problem...sometimes after engine warms uop ticking sound goes away..

  27. #127
    KnightDragon
    has no status.
    P Plate
    Join Date
    Aug 2008
    Posts
    154
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    phantom should use SEMI-synthetic or fully synthetic EO?
    different ppl talkin different thing...

    some said Fully can tahan hot..
    but some said phantom use Fully, engine makan EO faster..

  28. #128
    VidaK
    also has no status.
    SBF Lacer VidaK's Avatar
    Join Date
    Jan 2009
    Location
    Tampines
    Posts
    13,335
    Feedback Score
    3 (100%)
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by KnightDragon View Post
    phantom should use SEMI-synthetic or fully synthetic EO?
    different ppl talkin different thing...

    some said Fully can tahan hot..
    but some said phantom use Fully, engine makan EO faster..
    one school of thought:

    use mineral oil to run in > use fully syn oil for many years > use semi syn when it is older



    second school of though:

    use mineral oil to run in > use fully syn happily ever after



    I believe in the second school.

    anyway if your engine is eating engine oil, to extent that your oil level is below the minimum level after you ran 2000km after an oil change, something is very wrong with the engine... the piston ring needs serious attention as engine oil is leaking into the combustion chamber...

  29. #129
    KnightDragon
    has no status.
    P Plate
    Join Date
    Aug 2008
    Posts
    154
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by VidaK View Post
    ....
    anyway if your engine is eating engine oil, to extent that your oil level is below the minimum level after you ran 2000km after an oil change, something is very wrong with the engine... the piston ring needs serious attention as engine oil is leaking into the combustion chamber...
    i think still okay.. cos last time i checked still middle of XXX
    but today i met a fren.. he said fully syn makan EO faster than semi and
    phantom need thicker EO...

  30. #130
    VidaK
    also has no status.
    SBF Lacer VidaK's Avatar
    Join Date
    Jan 2009
    Location
    Tampines
    Posts
    13,335
    Feedback Score
    3 (100%)
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by KnightDragon View Post
    i think still okay.. cos last time i checked still middle of XXX
    but today i met a fren.. he said fully syn makan EO faster than semi and
    phantom need thicker EO...
    fully syn is smoother, hence easier to slip through gaps in your piston ring (there shouldn't be gaps)...

    thicker EO would give you a little less power, but better protection... I myself use thicker EO (at least 10w50)

  31. #131
    rixxer
    has no status.
    Class 2B rixxer's Avatar
    Join Date
    May 2005
    Location
    Sembawang
    Posts
    337
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Bike problem need advice, Thanks

    Hi all bro and sis,

    My bike when riding was ok , but during slow down the bike got a tek tek sound , only during slow down i hear this sound. can anyone advice on whats wrong with my bike? if clutch in then no sound.

    Thanks

     

     
  32. #132
    VidaK
    also has no status.
    SBF Lacer VidaK's Avatar
    Join Date
    Jan 2009
    Location
    Tampines
    Posts
    13,335
    Feedback Score
    3 (100%)
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)

    Default

    I believe its your chain... its probably loose... have a look at it... the sound disappears when you clutch in because the rear wheel is no longer pulling hard on the front sprocket... no resistance, no sound

  33. #133
    jtzx
    busy man
    SBF Phantom Knights jtzx's Avatar
    Join Date
    Jan 2009
    Location
    B I S H A N
    Posts
    6,248
    Feedback Score
    8 (90%)
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default

    timing chain could be the prob too..
    JOSHUA
    class2B -26/2/09
    class 2A -27/7/10
    class 3 - 6/1/11
    class 2 - 30/8/12



  34. #134
    lv3338
    has no status.
    Class 2A lv3338's Avatar
    Join Date
    Oct 2008
    Location
    South of Singapore
    Posts
    619
    Feedback Score
    0
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by rixxer View Post
    Hi all bro and sis,

    My bike when riding was ok , but during slow down the bike got a tek tek sound , only during slow down i hear this sound. can anyone advice on whats wrong with my bike? if clutch in then no sound.

    Thanks
    Do u have this problem previously ?

    I suspect could be slowed down..but having an inappropriate gear ratio.
    try to down your gear to see if u still have this problem. i faced the same problem also....but down the gears works...

    when u clutch in.... front sprocket is still connected...but the sound gone..as the gear is detached.... so even in inappropiate gear ration u hv this sound... so try and see if it work...as said.

  35. #135
    jbnewbike_2007
    has no status.
    L Plate
    Join Date
    Jun 2007
    Posts
    19
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Phantom TA200:Abnormal sound after step into Sixth Gear

    Hi,
    Recently I realised that my Phantom has abnormal sound on Sixth gear. Presently, I avoid the use this sixth gear. went to the motorshop at jurong east, told me that most probably my bike's gearbox problem. Need to do overhaul and change the gearbox .
    I first times came across this type of problem,
    I scared
    a) the high repairing cost [only has budget $500], worry after everything done, motorbike shop charge extra +++ for other part replacement
    and I'm not sure
    b) which motorbike shop good and experience on overhaul phantom bikes.
    c) Don't know how many day, they will complete the overhaul.

    Before I proceed to next, I hope bros can give me some advise.
    Thanks in advance.

  36. #136
    Silent Hunter
    has no status.
    SBF Lacer Silent Hunter's Avatar
    Join Date
    Jun 2007
    Location
    Singapore, Yishun
    Posts
    5,133
    Feedback Score
    4 (100%)
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default

    Possible solutions to your Phantom
    http://www.singaporebikes.com/forums...=199965&page=9

    If lazy to read, also nevermind. Most likely your gear 6 chui liao. Have to change gear 6.

    Go to planet motors. Blk 3007 Ubi Road 1, it's near Ubi Ave 3.
    http://www.singaporebikes.com/forums...ad.php?t=83442
    Motorcyclist are the nicest people on the road, try not to kill us.

  37. #137
    VidaK
    also has no status.
    SBF Lacer VidaK's Avatar
    Join Date
    Jan 2009
    Location
    Tampines
    Posts
    13,335
    Feedback Score
    3 (100%)
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)

    Default

    this is bad... yes you probably need to overhaul your gearbox... when my gear 5 was damaged, it led to my piston breaking off...

    planet can do the overhaul... I always see phantom engines being overhauled there... if you do overhaul there, it would probably take 3 days...

  38. #138
    jbnewbike_2007
    has no status.
    L Plate
    Join Date
    Jun 2007
    Posts
    19
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks silent hunter and vidak for a quick reply.
    May I know my budget of $500, whether it enough for overhaul the engine+changing the sixth gear.

  39. #139
    Cruiserian
    is riding CB400 Revo
    Class 2A Cruiserian's Avatar
    Join Date
    Oct 2009
    Posts
    748
    Feedback Score
    0
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by jbnewbike_2007 View Post
    Thanks silent hunter and vidak for a quick reply.
    May I know my budget of $500, whether it enough for overhaul the engine+changing the sixth gear.
    It depends if any of your other parts have problem too. You can let ah chong from planet knows your budget, and inform him to savage as many parts as possible, he will help. There was once my NSR150SP rear brake lever bended, thought i have to change a new 1, but he managed to savage for me by heating and bending it back.

  40. #140
    vibration_42
    has no status.
    Class 2 vibration_42's Avatar
    Join Date
    Feb 2008
    Location
    Central Singapore
    Posts
    898
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Bike cannot start! HELP ASAP!

    Guys, I hope someone here can help me out on this!

    I left my bike under my house for 6 weeks as I was going overseas. Then when I came back to try to start the bike, It didn't start.

    After a few tries, I manage to electrical start it. I let it idle for awhile before the bike died. Then I checked again and realise that I put the oil intake at OFF. So I turned it to on and tried to start the bike. This time, the bike didn't start. I tried to start it again for like the next 30mins but nothing happen. I heard a "tiak tiak" sound coming from the right side just below the seat area. I need to off the headlights to start the bike as leaving it on will prevent my electric start from working.

    And so I gave up on starting and went back home. As I read the forum last night, I realise that the sound means that the battery is very weak and must change it. Now there's a problem, can I start my battery after one night and ride to the bike shop to change it? Or should I attempt to buy the battery and change myself?

    Thanks so much!

  41. #141
    armani123sg
    has no status.
    TeePee armani123sg's Avatar
    Join Date
    Feb 2008
    Location
    Woodlands
    Posts
    2,832
    Feedback Score
    10 (100%)
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)

    Default

    Quote Originally Posted by vibration_42 View Post
    Guys, I hope someone here can help me out on this!

    I left my bike under my house for 6 weeks as I was going overseas. Then when I came back to try to start the bike, It didn't start.

    After a few tries, I manage to electrical start it. I let it idle for awhile before the bike died. Then I checked again and realise that I put the oil intake at OFF. So I turned it to on and tried to start the bike. This time, the bike didn't start. I tried to start it again for like the next 30mins but nothing happen. I heard a "tiak tiak" sound coming from the right side just below the seat area. I need to off the headlights to start the bike as leaving it on will prevent my electric start from working.

    And so I gave up on starting and went back home. As I read the forum last night, I realise that the sound means that the battery is very weak and must change it. Now there's a problem, can I start my battery after one night and ride to the bike shop to change it? Or should I attempt to buy the battery and change myself?

    Thanks so much!
    actually u can just manual start it n bring it to shop.

     

     
  42. #142
    vibration_42
    has no status.
    Class 2 vibration_42's Avatar
    Join Date
    Feb 2008
    Location
    Central Singapore
    Posts
    898
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Any idea how to manual Start? I'm quite new at this! haha, it's my first time that the bike have such a problem.

  43. #143
    vibration_42
    has no status.
    Class 2 vibration_42's Avatar
    Join Date
    Feb 2008
    Location
    Central Singapore
    Posts
    898
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Guys, any help here?

  44. #144
    dwpang
    will conquer tuas!
    P Plate dwpang's Avatar
    Join Date
    Jul 2009
    Location
    Little India
    Posts
    173
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    hi i wanna ask if there is any shops in the west (preferably jurong area) where i can service my ta200? wanna change engine oil btw... thanks!

  45. #145
    SNapEl
    wants to go for a looong ride~!!
    TeePee SNapEl's Avatar
    Join Date
    Aug 2007
    Posts
    2,398
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by vibration_42 View Post
    Guys, I hope someone here can help me out on this!

    I left my bike under my house for 6 weeks as I was going overseas. Then when I came back to try to start the bike, It didn't start.

    After a few tries, I manage to electrical start it. I let it idle for awhile before the bike died. Then I checked again and realise that I put the oil intake at OFF. So I turned it to on and tried to start the bike. This time, the bike didn't start. I tried to start it again for like the next 30mins but nothing happen. I heard a "tiak tiak" sound coming from the right side just below the seat area. I need to off the headlights to start the bike as leaving it on will prevent my electric start from working.

    And so I gave up on starting and went back home. As I read the forum last night, I realise that the sound means that the battery is very weak and must change it. Now there's a problem, can I start my battery after one night and ride to the bike shop to change it? Or should I attempt to buy the battery and change myself?

    Thanks so much!
    Quote Originally Posted by vibration_42 View Post
    Any idea how to manual Start? I'm quite new at this! haha, it's my first time that the bike have such a problem.
    Quote Originally Posted by vibration_42 View Post
    Guys, any help here?
    Battery is flat, probably can recharge. Search the forum to see if anyone does recharging of battery. May not be shop, can be just another forumer who is willing to help you. Push start your bike, ride to the shop/forumer house take out batter, recharge for an hour or so, put back carry on riding.

    If even after recharging the battery goes flat very fast, you probably need a new battery.

  46. #146
    vibration_42
    has no status.
    Class 2 vibration_42's Avatar
    Join Date
    Feb 2008
    Location
    Central Singapore
    Posts
    898
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    So I guess I definitely need to change a battery right? Hmm, any idea where to find a kind soul to help me recharge my battery?

  47. #147
    jtzx
    busy man
    SBF Phantom Knights jtzx's Avatar
    Join Date
    Jan 2009
    Location
    B I S H A N
    Posts
    6,248
    Feedback Score
    8 (90%)
    Mentioned
    18 Post(s)
    Tagged
    2 Thread(s)

    Default

    i guess the best way is to have it replace..

    Push start bike and ride to the nearest shop to have it replace =D
    JOSHUA
    class2B -26/2/09
    class 2A -27/7/10
    class 3 - 6/1/11
    class 2 - 30/8/12



  48. #148
    dwpang
    will conquer tuas!
    P Plate dwpang's Avatar
    Join Date
    Jul 2009
    Location
    Little India
    Posts
    173
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    yo jus wanna ask if there is any shops in the west (preferably jurong area) where i can service my ta200? wanna change engine oil btw... quite urgent sia... thanks!

  49. #149
    vibration_42
    has no status.
    Class 2 vibration_42's Avatar
    Join Date
    Feb 2008
    Location
    Central Singapore
    Posts
    898
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by jtzx View Post
    i guess the best way is to have it replace..

    Push start bike and ride to the nearest shop to have it replace =D

    Any idea where can I get the battery replaced at a good price?

  50. #150
    woo70
    200cc only
    L Plate woo70's Avatar
    Join Date
    Oct 2009
    Posts
    19
    Feedback Score
    0
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default TA200 - Start engine ... open a bit throttle ... engine died ..

    continue to electric start for about 10 times... engine started ... try to rev a bit, engine died again ... these happen for about 4 times then ok ... finally on my way . what could be the problem? bike was working well before service.
    This 7 yr old bike was just bought a month back. This morning just went for 1st servicing - change engine oil / change starter carbon / wash carburettor / change spark plug / change air suction / change air filter / change back tire ( $240 )

    Experience phantom biker , pls advise.

Page 3 of 35 FirstFirst 123456713 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •