Jump to content

Duper_four

Members
  • Content Count

    150
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Duper_four

  • Rank
    75cc
  • Birthday 08/01/1983
  1. ........................................
  2. i brake using engine...tried braking at 120km/hr in around 30m or so..haha can brake in time..but the tyres sort of skid abit...safer to use engine brake..cos if i use my fornt n rear brake onli...might not be able to brake in time..the brembo brakes im using are gd..but brake pads sux..haha... one ting to note is that..i realise xjr400 after goin above 9k rpm..the sound n power increase alot alot..=) not so much on 1st gear n 2nd gear.. but 3 gear start to drag can see the effect coming in...
  3. okie..mayb can mit up sumdays to share about maintain xjr400..recently bery buzy...mine's a old model...so far ok still nid to get used to it... fuel consumption also on the high side....
  4. haiz..tanks headache.....everything also $$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
  5. somehow abour sceptical about that sound...vvvv wary.....think its a serious problem..haha..aniway ask u again..how much to do the housing?
  6. hi all, last wk i went to view a XJR400, 97 reg for sales.. the idle sound of the engine got "log log log log" sound...the owner said it the time belt or time chain loose liao...BUt once i CLUTCH IN and go on riding..the sound gone..but once i put neutral and clutch free...the sound is back..what HAPPENED???? then the tank got a dent, quit obvious..however i think its not buang caused...more like an object hit against it... the bike except of this 2 major problem i dun see anithing wrong...the engine cover is scratchless, he got a engine guard thats y..haha My qns to all xrj exp
×
×
  • Create New...