Jump to content
  • Join SingaporeBikes.com today! Where Singapore Bikers Unite!

    Thank you for visiting SingaporeBikes.com - the largest website in Singapore dedicated to all things related to motorcycles and biking in general.

    Join us today as a member to enjoy all the features of the website such as:

    • Forums
    • Blogs
    • Picture/Video Gallery
    • Motorcycle Clubs
    • Event Calendar
    • and many more!

    Registering is free and takes less than 30 seconds! Join us today to share information, discuss about your modifications, and ask questions about your bike in general.

    Thank you for being a part of SingaporeBikes.com!

[Technical] Possible Solutions to your Phantom's Problem


Recommended Posts

wahaha.. thanks for all the info, got it fix already, was the brake lever unti spoil and also my brake disc is out of shap, but the strange thing is i never knock into anything or fall down, so also don't noe why out of shape, total damage is 110, the brake dis is second hand de.. wahaha painful man.. cheers.. but cannot save on the brake man can save out life

Link to post
Share on other sites
  • 4 months later...
  • Replies 1.8k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Hi, recently changed the top gasket seals of my TA200. Needed to do so because outside leaking engine oil, it was a big operation.

 

Then was changing my spark plug some week ago and noticed black oil on the lower part of the old plug. Also noticed my engine oil level still dropping and need monitoring and top up now and then.

 

So guys any ideas what could be wrong? Thanks alot and good day.

Link to post
Share on other sites
  • 10 months later...

Hi All,

 

I’ve purchased at Phantom 200 a few months ago.

 

Hope you guys can help me out.

 

1. Sometimes while accelerating, I have the tick tick sound. I stop throttling and it will stop. It’s kinda on and off. I’ve been reading the forum a lot and there could be an issue with the cam chain tensioner. However, the forum mentioned that I sound change if the tick tick sound is occurring during idle/neutral. I don’t have that issue during idle. Should I continue to ride with the tick tick sound or replace cam chain tensioner?

 

2. I have problems changing from gear 1 to neutral while stationary. I have to half clutch and throttle abit then I can change to neutral. Do I need to change my clutch? Or should I just leave it and use this technique to change to neutral while stationary?

 

Would appreciate the guidance. Thanks!

Link to post
Share on other sites
Hi All,

 

I’ve purchased at Phantom 200 a few months ago.

 

Hope you guys can help me out.

 

1. Sometimes while accelerating, I have the tick tick sound. I stop throttling and it will stop. It’s kinda on and off. I’ve been reading the forum a lot and there could be an issue with the cam chain tensioner. However, the forum mentioned that I sound change if the tick tick sound is occurring during idle/neutral. I don’t have that issue during idle. Should I continue to ride with the tick tick sound or replace cam chain tensioner?

 

2. I have problems changing from gear 1 to neutral while stationary. I have to half clutch and throttle abit then I can change to neutral. Do I need to change my clutch? Or should I just leave it and use this technique to change to neutral while stationary?

 

Would appreciate the guidance. Thanks!

 

gosh... so long hvnt post in a while..

almost forgot how to use the forum..

 

1) since u mention the ticking sound occurs only when throttling, check yr drivetrain aka chain & sprockets first.

if that section is fine, then the only thing possibly causing the sound is the CCT.

 

2) try adjusting yr clutch cable play first.

if that is still the same, clutch plates.

worse case scenario would be the shift shaft mechanism (I think).

 

TA200 is rly a relic nowadays, best to get it checked & replace/repair if need be.

 

Cheers!

Kev

我们都在不断赶路忘记了出路, 在失望中追求偶尔的满足..

Disclaimer:

The above information is obtained from third party sources for which I assume no responsibility.

While there is no reason to believe that the information is unreliable, no liability is accepted for any errors or inaccuracies.™®©

Link to post
Share on other sites
  • 4 weeks later...

My wife has a 2004 Phantom TA200 with 495km on the clock. It has been sitting for 14 years unused and I am getting it going again. I have struck a problem as I have had the carbie off for cleaning and now cannot work out where the myriad of rubber hoses go :( I have tried to find a service manual but it seems that is nowhere to be found on the internet so I am hoping someone can give me the necessary information. If it can be backed up with photos that would be good.

 

By the way, I have looked at the diagram on the side cover but it does not have enough info for me.

 

Thanks in advance.

Link to post
Share on other sites
My wife has a 2004 Phantom TA200 with 495km on the clock. It has been sitting for 14 years unused and I am getting it going again. I have struck a problem as I have had the carbie off for cleaning and now cannot work out where the myriad of rubber hoses go :( I have tried to find a service manual but it seems that is nowhere to be found on the internet so I am hoping someone can give me the necessary information. If it can be backed up with photos that would be good.

 

By the way, I have looked at the diagram on the side cover but it does not have enough info for me.

 

Thanks in advance.

 

 

No replies so far but if I can find a service manual then the problem will be solved. Does anyone have a service manual for sale or know where I can get one?

 

The old lady is 10 over yrs old my dear friend.

back then the internet hasn't yet so advance so it was either DIY or, send the trusted mech.

 

you can try your luck & inquire with FJT but I reckon chances are slim to nought.

 

another alternative that I thought it may help was the sticky thread here:

https://www.singaporebikes.com/forums/showthread.php/244355-Phantom-TA200-How-to-DIY-Guide(with-Pics)-Updated!-10-12-14

post #8.

 

not sure if it helps thou.

 

anyway, for future DIY, suggest you take an overall photo before operating.

that's what I do.

 

Last but not least, think most or all, seldom frequent here nowadays.

 

the forum is like, long gone.

 

Cheers!

Kev

我们都在不断赶路忘记了出路, 在失望中追求偶尔的满足..

Disclaimer:

The above information is obtained from third party sources for which I assume no responsibility.

While there is no reason to believe that the information is unreliable, no liability is accepted for any errors or inaccuracies.™®©

Link to post
Share on other sites
  • 2 weeks later...
  • 4 months later...

Hello All,

 

I have Phantom TA 200 which started giving problem when it rain or even wet road when I drive engine automatically stops and then I need to drag it side of the road wait for couple of minutes then it starts again. This has happened multiple times with me but I notice it happens only while it raining or I cross wet roads after rain (expressway specifically). Any suggestion what can be the problem?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...