Jump to content
  • Join SingaporeBikes.com today! Where Singapore Bikers Unite!

    Thank you for visiting SingaporeBikes.com - the largest website in Singapore dedicated to all things related to motorcycles and biking in general.

    Join us today as a member to enjoy all the features of the website such as:

    • Forums
    • Blogs
    • Picture/Video Gallery
    • Motorcycle Clubs
    • Event Calendar
    • and many more!

    Registering is free and takes less than 30 seconds! Join us today to share information, discuss about your modifications, and ask questions about your bike in general.

    Thank you for being a part of SingaporeBikes.com!

Recommended Posts

  • 1 year later...
  • Replies 64
  • Created
  • Last Reply

Top Posters In This Topic

hahas..all stock same as mine..140 still can go but no balls liao..what model or plate you're riding/having..what 2t you're using in case of piston jam..please note that our zzzzzz aren't meant for such high speed..can go doesn't mean can maintain..also do it safely..with no cars in front of you..avoid counter steering to overtake at such high speed..small bike not really much balance..don't eva use sotong tyres..ensure brakes are fine yea..tap on them when needed..

 

edit 1:pm me for more details..maybe we even can meet up to play play tour tour..

Link to post
Share on other sites
go till 120 rpm at 8 liao n engine sound lyk gonna explode anytime soon,frm 90-110 very slow to increase speed. is sikolene good? i dunno hw spell

 

okay..i understand the problem..the problem is i am facing the same problem as your after i tour for more than 70km in singapore roads..so i also a little puzzled..but throttle very responsive, just that gets jam at 120..if i'm not wrong, engine too hot..maybe got to do with air filter..but yours from start already like that can't hit 140 and above..gotta get a pro to enlighten..try under the rxz main page..sikolene? what you referring too? 2t? eo? wheels?rim?carb?

Link to post
Share on other sites

remember during my time, my 1993 rxz can go 150km/hr

i just don't have enough middle fingers....

- someone from SAF

 

Nov 2003 - May 2005 RxZ '93

May 2005 - Nov 2006 Daelim Magma '02

Nov 2006 - Oct 2009 S4 V-tech II '00

Oct 2009 - Aug 2010 W124 E200 '93

Aug 2010 - Date Getz 1.4 '06

Link to post
Share on other sites
  • 5 years later...
hmmm

 

the first answer.... got laquer mahh .. so no peeling off.

with y2k laquer will shine more.

but then... the spokes... i bought at ahboy jb.. the quality not that good

i meant was the between the spokes and the rim...that part..rust arr

damnshit! i guessed i never took care of my bike.. lazy ar..

one of this days.. i'll wash and scrape off the rust.

 

the second answer.... for your std pipe..

y not u change the silencer to the tzm silencer..

abit more degil.. or u can take out the spunch off the air filter box..

so the sound more nicer.

 

hmmm

 

:bounce: :bounce: :bounce:

 

That I totally gotta agree with u bro on the silencer change to TZM silencer...

I just got my license last year but I dunno much abt bike am still learning....

My friend mod my 3bs exhaust changing the silencer to his TZM and it really sounds evil but at the same time I am worry.. Why? I need some advise here.. Is it illegal to change RXZ silencer to TZM silencer? Your kind advise much appreciated..

 

I also have another problem.. Recently I realize my RXZ very hard to kick start.. Few days ago when the bike refuse to start, I check the spark plug and realize there is this petrol smell... When change spark plug all ok liao... Spark Plug I'm using G-Power NGK.. I dunno much abt bike and parts but could this be overflow of the petrol that go onto my piston causing the spark plug wet and hard to start? Could someone verify this and advise what I should do?

 

Thank you in advance all!!

 

*Im a new RXZ rider :)*

Link to post
Share on other sites
  • 10 months later...
  • 2 months later...

Hi all RXZ friends, last week while riding my rxz at expressway,suddenly the bike switched off, i quickly pulled the clutch and allow my bike to keep rolling till i reach expressway shoulder lane.Then while rolling,i tried to half clutch in hoping that the engine will start again but it did not. Only when my bike was about to stop then i tried half clutch again and the engine came back alive. But now i feel a huge difference as now my bike got no more power. So my question is...did the piston seize or jam? What is the remedy for this? I have just recently change to new piston,rebore,change brand new 2t pump and changed brand new original bosch carburettor. I hope RXZ experts here can share some advise and tips here...

Life is short, so don't make it shorter,

Complain less & make everyday, a new learning experience :thumb:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...