Jump to content
  • Join SingaporeBikes.com today! Where Singapore Bikers Unite!

    Thank you for visiting SingaporeBikes.com - the largest website in Singapore dedicated to all things related to motorcycles and biking in general.

    Join us today as a member to enjoy all the features of the website for FREE such as:

    Registering is free and takes less than 30 seconds! Join us today to share information, discuss about your modifications, and ask questions about your bike in general.

    Thank you for being a part of SingaporeBikes.com!

Signal light doesn't blink after changing from bulb to led


Go to solution Solved by adesmond2,

Recommended Posts

Hey all, I'm new to the DIY scene and I wanted to try changing my rear signal light since I heard its plug and play.
For the front signal light, it is still using bulb, whereas the rear signal light, I changed it to led.
Once I've plug in everything and check to see if its working. The signal light lid up but its not blinking.

Do I need to change my stock signal relay to an aftermarket signal relay for the led to blink?
Picture attached is an aftermarket signal relay that you can modify the blink rate.

(Do note that I have zero knowledge of electronics, please educate me!)

aftermarket-signal-relay.png

Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

  • Solution
12 hours ago, M3DU5A said:

Hey all, I'm new to the DIY scene and I wanted to try changing my rear signal light since I heard its plug and play.
For the front signal light, it is still using bulb, whereas the rear signal light, I changed it to led.
Once I've plug in everything and check to see if its working. The signal light lid up but its not blinking.

Do I need to change my stock signal relay to an aftermarket signal relay for the led to blink?
Picture attached is an aftermarket signal relay that you can modify the blink rate.

(Do note that I have zero knowledge of electronics, please educate me!)

aftermarket-signal-relay.png

Yes.. you need to change the relay cuz the stock relay is adjusted to the voltage.. As led is lower voltage.. 

  • Thanks 1

Kindly read thru at least the intro section first before decide to post any comments.... thanks... :cool:

 

Please proceed to this website/web link if you guys have any technical issues on Kawasaki Kips/KR150, I'll update the 1st POST as and when there's a new question. Newbies questions on the top as well. :)

 

 

 

http://www.singaporebikes.com/forums/showthread.php?p=6285055#post6285055

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...